From: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Date: Fri, 4 Oct 2019 12:44:07 +0000 (+0200)
Subject: ath79: fix SUPPORTED_DEVICES for ubnt_nanostation-m
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=f473ce6f231bb9f8913be50e850c771b3463fa14;p=oweals%2Fopenwrt.git

ath79: fix SUPPORTED_DEVICES for ubnt_nanostation-m

The ar71xx images for the Ubiquiti NanoStation M (XM) devices use
"nanostation-m" as board name, but the ath79 images are only
compatible with the "nano-m" board name, so sysupgrade complains.

By changing this additional supported device, sysupgrade smoothly
upgrades from ar71xx to ath79.

Ref: openwrt#2418

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---

diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 801b0128ac..ddf9f55d11 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -154,7 +154,7 @@ TARGET_DEVICES += ubnt_nanostation-ac-loco
 define Device/ubnt_nanostation-m
   $(Device/ubnt-xm)
   DEVICE_MODEL := Nanostation M
-  SUPPORTED_DEVICES += nano-m
+  SUPPORTED_DEVICES += nanostation-m
 endef
 TARGET_DEVICES += ubnt_nanostation-m