From: Florian Fainelli <florian@openwrt.org>
Date: Sun, 26 Jul 2009 18:09:20 +0000 (+0000)
Subject: override sed configuration to work with FreeBSD (#4531)
X-Git-Tag: reboot~22841
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=b78a0f257e12c2f961ed2f346f238fdbe860a971;p=oweals%2Fopenwrt.git

override sed configuration to work with FreeBSD (#4531)

SVN-Revision: 17022
---

diff --git a/tools/sed/Makefile b/tools/sed/Makefile
index f15299c96c..423e2982e0 100644
--- a/tools/sed/Makefile
+++ b/tools/sed/Makefile
@@ -17,6 +17,14 @@ export SED:=
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Build/Configure
+	( cd $(PKG_BUILD_DIR); \
+		./configure \
+		--prefix=$(STAGING_DIR_HOST) \
+		--infodir=/usr/info \
+	)
+endef
+
 define Host/Compile
 	$(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)"
 endef