From: Mirko Vogt <mirko@openwrt.org>
Date: Sat, 4 Dec 2010 00:11:09 +0000 (+0000)
Subject: disable libtool fixups in trunk globally
X-Git-Tag: reboot~18223
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=b599f7dc42e33e6c04523deefabc316501e92baf;p=oweals%2Fopenwrt.git

disable libtool fixups in trunk globally

SVN-Revision: 24234
---

diff --git a/include/autotools.mk b/include/autotools.mk
index 1ddb49b7d4..7e251ead53 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -49,17 +49,18 @@ define remove_version_check
 	fi
 endef
 
-ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool remove_version_check
-  Hooks/Configure/Post += update_libtool
-  Hooks/InstallDev/Post += libtool_fixup_libdir
-endif
-
-ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
-  Hooks/Configure/Post += update_libtool_ucxx
-  Hooks/InstallDev/Post += libtool_fixup_libdir
-endif
+# XXX the libtool fixups got deactivated in the course of switching to libtool2 in trunk XXX
+# ifneq ($(filter libtool,$(PKG_FIXUP)),)
+#   PKG_BUILD_DEPENDS += libtool
+#   Hooks/Configure/Pre += update_libtool remove_version_check
+#   Hooks/Configure/Post += update_libtool
+#   Hooks/InstallDev/Post += libtool_fixup_libdir
+# endif
+# 
+# ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
+#   PKG_BUILD_DEPENDS += libtool
+#   Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
+#   Hooks/Configure/Post += update_libtool_ucxx
+#   Hooks/InstallDev/Post += libtool_fixup_libdir
+# endif