From: Gabor Juhos <juhosg@openwrt.org>
Date: Fri, 1 Nov 2013 18:33:18 +0000 (+0000)
Subject: ar71xx: always enable hw ecc support for the ar934x-nfc module
X-Git-Tag: reboot~8779
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=b2bc45d21e058f5e447f76425e98dec7d817dfae;p=oweals%2Fopenwrt.git

ar71xx: always enable hw ecc support for the ar934x-nfc module

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 38634
---

diff --git a/target/linux/ar71xx/modules.mk b/target/linux/ar71xx/modules.mk
index 83747d6ce2..4530708de9 100644
--- a/target/linux/ar71xx/modules.mk
+++ b/target/linux/ar71xx/modules.mk
@@ -40,7 +40,9 @@ $(eval $(call KernelPackage,leds-wndr3700-usb))
 define KernelPackage/nand-ar934x
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Atheros AR934x NAND flash controller driver
-  KCONFIG:=CONFIG_MTD_NAND_AR934X
+  KCONFIG:=\
+    CONFIG_MTD_NAND_AR934X \
+    CONFIG_MTD_NAND_AR934X_HW_ECC=y
   DEPENDS:=@TARGET_ar71xx +kmod-nand
   FILES:=$(LINUX_DIR)/drivers/mtd/nand/ar934x_nfc.ko
   AUTOLOAD:=$(call AutoLoad,25,ar934x_nfc)