From: 张鹏 <sd20@qxwlan.com>
Date: Tue, 17 Jul 2018 10:11:21 +0000 (+0800)
Subject: ar71xx:add support for E750A v4
X-Git-Tag: v19.07.0-rc1~3013
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=ac03d51a3f4daa2f6a2a83f041dcd71674a9f724;p=oweals%2Fopenwrt.git

ar71xx:add support for E750A v4

Qxwlan E750A v4 is based on Qualcomm QCA9344.

Specification:

 - 560/450/225 MHz (CPU/DDR/AHB)
 - 128 MB of RAM (DDR2)
 - 8/16 MB of FLASH (SPI NOR)
 - 2T2R 5G GHz (AR9344)
 - 2x 10/100 Mbps Ethernet (one port with PoE support)
 - 1x miniPCIe slot (USB 2.0 bus only)
 - 7x LED (6 driven by GPIO)
 - 1x button (reset)
 - 1x DC jack for main power input (9-48 V)
 - UART (J23) and LEDs (J2) headers on PCB

Flash instruction (using U-Boot CLI and tftp server):

 - Configure PC with static IP 192.168.1.10 and tftp server.
 - Rename "sysupgrade" filename to "firmware.bin" and place it in tftp
   server directory.
 - Connect PC with one of RJ45 ports, power up the board and press
   "enter" key to access U-Boot CLI.
 - Use the following command to update the device to OpenWrt: "run lfw".

Flash instruction (using U-Boot web-based recovery):

 - Configure PC with static IP 192.168.1.xxx(2-254)/24.
 - Connect PC with one of RJ45 ports, press the reset button, power up
   the board and keep button pressed for around 6-7 seconds, until LEDs
   start flashing.
 - Open your browser and enter 192.168.1.1, select "sysupgrade" image
   and click the upgrade button.

Signed-off-by: 张鹏 <sd20@qxwlan.com>
---

diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 3db4305043..2b3e8b739c 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -66,7 +66,8 @@ cpe830|\
 cpe870|\
 dr531|\
 e600g-v2|\
-e600gac-v2)
+e600gac-v2|\
+e750a-v2)
 	ucidef_set_led_netdev "lan" "LAN" "$board:green:lan" "eth0"
 	ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
 
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 2a2fda3ac8..00b839ef59 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -26,6 +26,7 @@ get_status_led() {
 	e1700ac-v2|\
 	e558-v2|\
 	e600gac-v2|\
+	e750a-v4|\
 	eap120|\
 	minibox-v1|\
 	packet-squirrel|\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 7c0d53b4cb..adeffe96a1 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -684,6 +684,9 @@ ar71xx_board_detect() {
 	*"E600GAC v2")
 		name="e600gac-v2"
 		;;
+	*"E750A v4")
+		name="e750a-v4"
+		;;
 	*"EAP120")
 		name="eap120"
 		tplink_pharos_board_detect "$(tplink_pharos_get_model_string | tr -d '\r')"
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 2110eb238e..7db4899dc7 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -253,6 +253,7 @@ platform_check_image() {
 	e558-v2|\
 	e600g-v2|\
 	e600gac-v2|\
+	e750a-v4|\
 	ebr-2310-c1|\
 	ens202ext|\
 	epg5000|\
diff --git a/target/linux/ar71xx/config-4.9 b/target/linux/ar71xx/config-4.9
index 58cd40962a..72a91a1f2b 100644
--- a/target/linux/ar71xx/config-4.9
+++ b/target/linux/ar71xx/config-4.9
@@ -103,6 +103,7 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_E2100L is not set
 # CONFIG_ATH79_MACH_E558_V2 is not set
 # CONFIG_ATH79_MACH_E600G_V2 is not set
+# CONFIG_ATH79_MACH_E750A_V4 is not set
 # CONFIG_ATH79_MACH_EAP120 is not set
 # CONFIG_ATH79_MACH_EAP300V2 is not set
 # CONFIG_ATH79_MACH_EAP7660D is not set
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 3cd90a446b..db410b6607 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -733,6 +733,17 @@ config ATH79_MACH_E600G_V2
 	select ATH79_DEV_USB
 	select ATH79_DEV_WMAC
 
+config ATH79_MACH_E750A_V4
+	bool "Qxwlan E750A v4 support"
+	select SOC_AR934X
+	select ATH79_DEV_AP9X_PCI if PCI
+	select ATH79_DEV_ETH
+	select ATH79_DEV_GPIO_BUTTONS
+	select ATH79_DEV_LEDS_GPIO
+	select ATH79_DEV_M25P80
+	select ATH79_DEV_USB
+	select ATH79_DEV_WMAC
+
 config ATH79_MACH_ESR900
 	bool "EnGenius ESR900 board support"
 	select SOC_QCA955X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 690738e1e6..4453e369a3 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -114,6 +114,7 @@ obj-$(CONFIG_ATH79_MACH_DRAGINO2)		+= mach-dragino2.o
 obj-$(CONFIG_ATH79_MACH_E1700AC_V2)		+= mach-e1700ac-v2.o
 obj-$(CONFIG_ATH79_MACH_E558_V2)		+= mach-e558-v2.o
 obj-$(CONFIG_ATH79_MACH_E600G_V2)		+= mach-e600g-v2.o
+obj-$(CONFIG_ATH79_MACH_E750A_V4)		+= mach-e750a-v4.o
 obj-$(CONFIG_ATH79_MACH_EAP120)			+= mach-eap120.o
 obj-$(CONFIG_ATH79_MACH_EAP300V2)		+= mach-eap300v2.o
 obj-$(CONFIG_ATH79_MACH_EAP7660D)		+= mach-eap7660d.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-e750a-v4.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-e750a-v4.c
new file mode 100644
index 0000000000..7cf3292c68
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-e750a-v4.c
@@ -0,0 +1,122 @@
+/*
+ *  Qxwlan E750A v4 board support
+ *
+ *  Copyright (C) 2017 Peng Zhang <sd20@qxwlan.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/phy.h>
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#define E750A_V4_GPIO_LED_SYS	14
+#define E750A_V4_GPIO_LED_LAN	19
+#define E750A_V4_GPIO_LED_WAN	18
+#define E750A_V4_GPIO_LED_DS10	15
+#define E750A_V4_GPIO_LED_DS20	20
+#define E750A_V4_GPIO_LED_WLAN	21
+
+#define E750A_V4_GPIO_BTN_RESET	12
+
+#define E750A_V4_KEYS_POLL_INTERVAL	20	/* msecs */
+#define E750A_V4_KEYS_DEBOUNCE_INTERVAL	(3 * E750A_V4_KEYS_POLL_INTERVAL)
+
+static struct gpio_led e750a_v4_leds_gpio[] __initdata = {
+	{
+		.name		= "e750a-v4:green:system",
+		.gpio		= E750A_V4_GPIO_LED_SYS,
+		.active_low	= 1,
+	},
+	{
+		.name		= "e750a-v4:green:lan",
+		.gpio		= E750A_V4_GPIO_LED_LAN,
+		.active_low	= 1,
+	},
+	{
+		.name		= "e750a-v4:green:wan",
+		.gpio		= E750A_V4_GPIO_LED_WAN,
+		.active_low	= 1,
+	},
+	{
+		.name		= "e750a-v4:green:wlan",
+		.gpio		= E750A_V4_GPIO_LED_WLAN,
+		.active_low	= 1,
+	},
+	{
+		.name		= "e750a-v4:green:ds10",
+		.gpio		= E750A_V4_GPIO_LED_DS10,
+		.active_low	= 1,
+	},
+	{
+		.name		= "e750a-v4:green:ds20",
+		.gpio		= E750A_V4_GPIO_LED_DS20,
+		.active_low	= 1,
+	},
+};
+
+static struct gpio_keys_button e750a_v4_gpio_keys[] __initdata = {
+	{
+		.desc           = "reset",
+		.type           = EV_KEY,
+		.code           = KEY_RESTART,
+		.debounce_interval = E750A_V4_KEYS_DEBOUNCE_INTERVAL,
+		.gpio           = E750A_V4_GPIO_BTN_RESET,
+		.active_low     = 1,
+	},
+};
+
+
+static void __init e750a_v4_setup(void)
+{
+	u8 *mac = (u8 *) KSEG1ADDR(0x1f050400);
+	u8 *art = (u8 *) KSEG1ADDR(0x1f061000);
+
+	ath79_register_m25p80(NULL);
+
+	ath79_register_leds_gpio(-1, ARRAY_SIZE(e750a_v4_leds_gpio),
+			e750a_v4_leds_gpio);
+	ath79_register_gpio_keys_polled(-1, E750A_V4_KEYS_POLL_INTERVAL,
+			ARRAY_SIZE(e750a_v4_gpio_keys),
+			e750a_v4_gpio_keys);
+
+	ath79_register_mdio(1, 0x0);
+	ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_SW_ONLY_MODE);
+
+	/* GMAC1 is connected to the internal switch */
+	ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+	ath79_init_mac(ath79_eth1_data.mac_addr, mac, 0);
+	ath79_register_eth(1);
+
+	/* GMAC0 is connected to the PHY4 of the internal switch */
+	ath79_switch_data.phy4_mii_en = 1;
+	ath79_switch_data.phy_poll_mask = BIT(4);
+	ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+	ath79_eth0_data.phy_mask = BIT(4);
+	ath79_eth0_data.mii_bus_dev = &ath79_mdio1_device.dev;
+	ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+	ath79_register_eth(0);
+
+	ath79_register_pci();
+	ath79_register_usb();
+	ath79_register_wmac(art, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_E750A_V4, "E750A-V4", "Qxlan E750A v4",
+		e750a_v4_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index de1efab3a2..d304b9eb80 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -108,6 +108,7 @@ enum ath79_mach_type {
 	ATH79_MACH_E558_V2,			/* Qxwlan E558 v2 */
 	ATH79_MACH_E600G_V2,			/* Qxwlan E600G v2 */
 	ATH79_MACH_E600GAC_V2,			/* Qxwlan E600GAC v2 */
+	ATH79_MACH_E750A_V4,			/* Qxwlan E750A v4 */
 	ATH79_MACH_EAP120,			/* TP-LINK EAP120 */
 	ATH79_MACH_EAP300V2,			/* EnGenius EAP300 v2 */
 	ATH79_MACH_EAP7660D,			/* Senao EAP7660D */
diff --git a/target/linux/ar71xx/generic/config-default b/target/linux/ar71xx/generic/config-default
index df492da60e..9559794d1d 100644
--- a/target/linux/ar71xx/generic/config-default
+++ b/target/linux/ar71xx/generic/config-default
@@ -75,6 +75,7 @@ CONFIG_ATH79_MACH_E1700AC_V2=y
 CONFIG_ATH79_MACH_E2100L=y
 CONFIG_ATH79_MACH_E558_V2=y
 CONFIG_ATH79_MACH_E600G_V2=y
+CONFIG_ATH79_MACH_E750A_V4=y
 CONFIG_ATH79_MACH_EAP120=y
 CONFIG_ATH79_MACH_EAP300V2=y
 CONFIG_ATH79_MACH_EAP7660D=y
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index dedc19d52c..d9da3be782 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -384,6 +384,25 @@ define Device/e600gac-v2-8M
 endef
 TARGET_DEVICES += e600gac-v2-8M
 
+define Device/e750a-v4-16M
+  DEVICE_TITLE := Qxwlan E750A v4 (16MB flash)
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+  BOARDNAME := E750A-V4
+  SUPPORTED_DEVICES := e750a-v4
+  IMAGE_SIZE := 15936k
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art),-(firmware)
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+	append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e750a-v4-16M
+
+define Device/e750a-v4-8M
+  $(Device/e750a-v4-16M)
+  DEVICE_TITLE := Qxwlan E750A v4 (8MB flash)
+  IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e750a-v4-8M
+
 define Device/ew-balin
   DEVICE_TITLE := Embedded Wireless Balin Platform
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea