From: David Bauer <mail@david-bauer.net>
Date: Sat, 18 Aug 2018 12:01:59 +0000 (+0200)
Subject: ath79: fix TL-MR3020 image metadata
X-Git-Tag: v19.07.0-rc1~2768
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=98d377037963068218f168f6ac19c3ade6c0e398;p=oweals%2Fopenwrt.git

ath79: fix TL-MR3020 image metadata

Sysupgrading to ath79 from ar71xx currently fails because of mismatching
supported_devices. ar71xx is expecting "tl-mr3020" which is missing in
the ath79 image. Upgrading from ath79 is unaffected, as the image
contains the old string for ar71xx and the new one coming from the
device-tree.

Signed-off-by: David Bauer <mail@david-bauer.net>
---

diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 6ccc9d7dba..dadcd24b42 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -17,7 +17,7 @@ define Device/tplink_tl-mr3020-v1
   DEVICE_TITLE := TP-LINK TL-MR3020 v1
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
   TPLINK_HWID := 0x30200001
-  SUPPORTED_DEVICES += tl-mr3020-v1
+  SUPPORTED_DEVICES += tl-mr3020
 endef
 TARGET_DEVICES += tplink_tl-mr3020-v1