From: Imre Kaloz <kaloz@openwrt.org>
Date: Fri, 13 Jun 2008 12:58:28 +0000 (+0000)
Subject: temporary hack to fixup the mach id for the wrt350nv2
X-Git-Tag: reboot~26299
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=983b22aa95eed2fedc109d505105d1a46e8bdfa0;p=oweals%2Fopenwrt.git

temporary hack to fixup the mach id for the wrt350nv2

SVN-Revision: 11459
---

diff --git a/target/linux/orion/image/Makefile b/target/linux/orion/image/Makefile
index 073c24f63e..073317fecd 100644
--- a/target/linux/orion/image/Makefile
+++ b/target/linux/orion/image/Makefile
@@ -8,15 +8,15 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/Prepare
-	cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+#
+# XXX - FIXME, we hardcode for the WRT350N v2 for now
+#
+	echo -en "\x61\x70\xa0\xe3\x06\x7c\x87\xe3" > $(KDIR)/uImage
+	cat $(LINUX_DIR)/arch/arm/boot/uImage >> $(KDIR)/uImage
 endef
 
 define Image/BuildKernel
 	cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
-#
-# XXX - FIXME
-#
-#	BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
 endef
 
 define Image/Build
@@ -26,7 +26,7 @@ endef
 define Image/Build/squashfs
 	$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 	( \
-		dd if=$(LINUX_DIR)/arch/arm/boot/uImage bs=1024k conv=sync; \
+		dd if=$(KDIR)/uImage bs=1024k conv=sync; \
 		dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
 	) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
 endef