From: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Date: Fri, 14 Sep 2018 20:52:39 +0000 (+0100)
Subject: iproute2: q_cake: Also print nonat, nowash and no-ack-filter keywords
X-Git-Tag: v18.06.2~364
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=4f6ad3c13ace1d341179ad82f417aa0ce5adf51d;p=oweals%2Fopenwrt.git

iproute2: q_cake: Also print nonat, nowash and no-ack-filter keywords

Pull in latest upstream tweaks:
Similar to the previous patch for no-split-gso, the negative keywords for
'nat', 'wash' and 'ack-filter' were not printed either. Add those as well.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
(cherry picked from commit 033f02b9b5580e67e2f1b623f62da60d645e7ba2)
---

diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 91092b2f51..2c13e276fb 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=4.16.0
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
diff --git a/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch b/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
index 038ca23337..1eebb729c3 100644
--- a/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
+++ b/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
@@ -854,7 +854,7 @@
  TCMODULES += e_bpf.o
 --- /dev/null
 +++ b/tc/q_cake.c
-@@ -0,0 +1,801 @@
+@@ -0,0 +1,805 @@
 +// SPDX-License-Identifier: GPL-2.0 OR BSD-3-Clause
 +
 +/*
@@ -1325,6 +1325,8 @@
 +
 +	if (nat)
 +		print_string(PRINT_FP, NULL, "nat ", NULL);
++	else
++		print_string(PRINT_FP, NULL, "nonat ", NULL);
 +	print_bool(PRINT_JSON, "nat", NULL, nat);
 +
 +	if (tb[TCA_CAKE_WASH] &&
@@ -1365,6 +1367,8 @@
 +
 +	if (wash)
 +		print_string(PRINT_FP, NULL, "wash ", NULL);
++	else
++		print_string(PRINT_FP, NULL, "nowash ", NULL);
 +	print_bool(PRINT_JSON, "wash", NULL, wash);
 +
 +	if (ingress)
@@ -1377,7 +1381,7 @@
 +	else if (ack_filter == CAKE_ACK_FILTER)
 +		print_string(PRINT_ANY, "ack-filter", "ack-filter ", "enabled");
 +	else
-+		print_string(PRINT_JSON, "ack-filter", NULL, "disabled");
++		print_string(PRINT_ANY, "ack-filter", "no-ack-filter ", "disabled");
 +
 +	if (split_gso)
 +		print_string(PRINT_FP, NULL, "split-gso ", NULL);