From: Andy Walsh <andy.walsh44+github@gmail.com>
Date: Tue, 7 Aug 2018 15:46:42 +0000 (+0200)
Subject: gettext-full: host compile with -fpic
X-Git-Tag: v18.06.2~139
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=38e99cb37942716c3ae2d4d4e083fc38469dfcf5;p=oweals%2Fopenwrt.git

gettext-full: host compile with -fpic

Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
(backported from 2bbc9376c6c081a8db491f047e32091da6ba0016)
---

diff --git a/package/libs/gettext-full/Makefile b/package/libs/gettext-full/Makefile
index db6aee7508..4cb8d8d618 100644
--- a/package/libs/gettext-full/Makefile
+++ b/package/libs/gettext-full/Makefile
@@ -77,6 +77,8 @@ HOST_CONFIGURE_VARS += \
 	am_cv_func_iconv=no \
 	ac_cv_header_iconv_h=no \
 
+HOST_CFLAGS += $(HOST_FPIC)
+
 define Build/InstallDev
 	$(INSTALL_DIR) $(1)/usr/lib/libintl-full/include
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(1)/usr/lib/libintl-full/include/