projects
/
oweals
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1090511
)
Change ipkg invocation and add -force-defaults option
author
Nicolas Thill
<nico@openwrt.org>
Sun, 6 Mar 2005 11:02:08 +0000
(11:02 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Sun, 6 Mar 2005 11:02:08 +0000
(11:02 +0000)
SVN-Revision: 313
openwrt/rules.mk
patch
|
blob
|
history
diff --git
a/openwrt/rules.mk
b/openwrt/rules.mk
index 681d4f9b1cbaabaf9241fa29fdf7b93a0d04a508..4218bbf1b2df557f66e23b3308a3f6ef1a5a434a 100644
(file)
--- a/
openwrt/rules.mk
+++ b/
openwrt/rules.mk
@@
-112,7
+112,8
@@
endif
# invoke ipkg with configuration in $(STAGING_DIR)/etc/ipkg.conf
-IPKG := PATH="$(TARGET_PATH)" IPKG_CONF_DIR=$(STAGING_DIR)/etc ipkg -force-depends
+IPKG := IPKG_CONF_DIR=$(STAGING_DIR)/etc $(TARGET_DIR)/bin/ipkg -force-defaults -force-depends
+IPKG_STATE_DIR := $(TARGET_DIR)/usr/lib/ipkg
# invoke ipkg-build with some default options
IPKG_BUILD := PATH="$(TARGET_PATH)" ipkg-build -c -o root -g root