base-files: hotplug-call: exit success when dir is absent
authorYousong Zhou <yszhou4tech@gmail.com>
Mon, 28 Oct 2019 09:41:08 +0000 (09:41 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Tue, 29 Oct 2019 13:28:49 +0000 (13:28 +0000)
"block mount" invokes "hotplug-call mount".  It emits the following
error when mount is not present

hotplug-call call failed

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
package/base-files/Makefile
package/base-files/files/sbin/hotplug-call

index f105d2cd2768ad19221ef07b25842da77a78424c..addbac8664470c43ac608c33e4a2c4ad7f3e3071 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=205
+PKG_RELEASE:=206
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index 28e957c3982ae070c7e8729410f45f160ea8b6a4..f595b9e75fa958ca6ade484134e625050bd8c7d5 100755 (executable)
@@ -11,8 +11,8 @@ USER=root
 export PATH LOGNAME USER
 export DEVICENAME="${DEVPATH##*/}"
 
-[ \! -z "$1" -a -d /etc/hotplug.d/$1 ] && {
+if [ \! -z "$1" -a -d /etc/hotplug.d/$1 ]; then
        for script in $(ls /etc/hotplug.d/$1/* 2>&-); do (
                [ -f $script ] && . $script
        ); done
-}
+fi