kernel: bump 4.9 to 4.9.172
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 2 May 2019 12:34:36 +0000 (14:34 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 6 May 2019 10:44:26 +0000 (12:44 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.9/950-0028-kbuild-Ignore-dtco-targets-when-filtering-symbols.patch
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 2f12a2b06103eccf3aaf376f1b75586c26d36399..d1ccfebbd602c78c9b40d9987b8966e352f548ce 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .171
+LINUX_VERSION-4.9 = .172
 LINUX_VERSION-4.14 = .114
 
-LINUX_KERNEL_HASH-4.9.171 = 431cd992bf74da9851dd5938dbe45ff7577219b84b237ae5e30067d483b57f01
+LINUX_KERNEL_HASH-4.9.172 = 49428e30989cc0b069a6f4b7bc08988deb02d10f910ca0c4d1e44b22155eb40e
 LINUX_KERNEL_HASH-4.14.114 = b75e1dcfabc8d18051a07cbf9b60eaee8ac470a2311fed20447fd0d022c19e15
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 87008b75f0683177f4843077e47570aa56fbed2a..fc994edc4e59aae23c1ac74ca5b337aa96b52704 100644 (file)
                return false;
  
        return true;
-@@ -633,13 +637,13 @@ static inline void ipv6_addr_set_v4mappe
+@@ -604,13 +608,13 @@ static inline void ipv6_addr_set_v4mappe
   */
  static inline int __ipv6_addr_diff32(const void *token1, const void *token2, int addrlen)
  {
                if (xb)
                        return i * 32 + 31 - __fls(ntohl(xb));
        }
-@@ -808,17 +812,18 @@ static inline int ip6_default_np_autolab
+@@ -779,17 +783,18 @@ static inline int ip6_default_np_autolab
  static inline void ip6_flow_hdr(struct ipv6hdr *hdr, unsigned int tclass,
                                __be32 flowlabel)
  {
index 8e7002436be09e01f3879e121b73ad498a7d22ac..37bcc65ed5408e69ec46d061b7e1516bff191905 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH] kbuild: Ignore dtco targets when filtering symbols
 
 --- a/scripts/Kbuild.include
 +++ b/scripts/Kbuild.include
-@@ -296,7 +296,7 @@ ksym_dep_filter =
+@@ -294,7 +294,7 @@ ksym_dep_filter =
            $(CPP) $(call flags_nodeps,c_flags) -D__KSYM_DEPS__ $< ;;        \
          as_*_S|cpp_s_S)                                                    \
            $(CPP) $(call flags_nodeps,a_flags) -D__KSYM_DEPS__ $< ;;        \
index 6e6a9c34ec344920e8c54d1d4906981a92f28cd2..9a490f5bb68e186e2be47f28127f43853eed5bbe 100644 (file)
@@ -696,7 +696,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5084,7 +5084,7 @@ static void port_event(struct usb_hub *h
+@@ -5081,7 +5081,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
@@ -707,7 +707,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
                msleep(100);    /* Cool down */
 --- a/drivers/usb/core/message.c
 +++ b/drivers/usb/core/message.c
-@@ -1923,6 +1923,85 @@ free_interfaces:
+@@ -1922,6 +1922,85 @@ free_interfaces:
        if (cp->string == NULL &&
                        !(dev->quirks & USB_QUIRK_CONFIG_INTF_STRINGS))
                cp->string = usb_cache_string(dev, cp->desc.iConfiguration);
index 9a211320338133af51bdf08b328c2091dfdffcaa..f2f1f6f81e7a008b4c27fa6286d733cba92104a6 100644 (file)
@@ -1095,7 +1095,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                dma_intr_ena = smsc9420_reg_read(pd, DMAC_INTR_ENA);
 --- a/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c
 +++ b/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c
-@@ -2702,7 +2702,7 @@ static int stmmac_poll(struct napi_struc
+@@ -2700,7 +2700,7 @@ static int stmmac_poll(struct napi_struc
  
        work_done = stmmac_rx(priv, budget);
        if (work_done < budget) {
index c1aff504753cab7ef7cb7e2a4faed1746afb470c..310104de7c04375df74cb9280e01e335e66e685a 100644 (file)
@@ -156,7 +156,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        int ret;
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4443,6 +4443,14 @@ hub_port_init(struct usb_hub *hub, struc
+@@ -4440,6 +4440,14 @@ hub_port_init(struct usb_hub *hub, struc
        else
                speed = usb_speed_string(udev->speed);