kernel: bump 4.9 to 4.9.175
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 13 May 2019 08:54:43 +0000 (10:54 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 15 May 2019 09:28:40 +0000 (11:28 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/310-lib-add-rle-decompression.patch
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/generic/pending-4.9/530-jffs2_make_lzma_available.patch
target/linux/generic/pending-4.9/630-packet_socket_type.patch
target/linux/lantiq/patches-4.9/0030-GPIO-add-named-gpio-exports.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch
target/linux/layerscape/patches-4.9/818-vfio-support-layerscape.patch

index 311a9b5e86d71781f61101167f7f7244701ac157..70ae299abf13c08a8f3c591c706ffb22738531f7 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .172
+LINUX_VERSION-4.9 = .175
 LINUX_VERSION-4.14 = .115
 
-LINUX_KERNEL_HASH-4.9.172 = 49428e30989cc0b069a6f4b7bc08988deb02d10f910ca0c4d1e44b22155eb40e
+LINUX_KERNEL_HASH-4.9.175 = d98434f91f9df2bf36c7896ca747b7cf98be2e3a491073fd26e3f53cda07500c
 LINUX_KERNEL_HASH-4.14.115 = b7ae61711a1323053d68fd47911b92977afd526d302755518e42744251516186
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index d8480125a93033b20458fc8753541f5a00706664..e64b89adcd3ccfabb6aa5001c033b8019852aa09 100644 (file)
@@ -12,7 +12,7 @@
  # ZLIB_INFLATE; DECOMPRESS_GZIP is just a wrapper.)
 --- a/lib/Makefile
 +++ b/lib/Makefile
-@@ -120,6 +120,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
+@@ -121,6 +121,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
  obj-$(CONFIG_RAID6_PQ) += raid6/
  obj-$(CONFIG_LZMA_COMPRESS) += lzma/
  obj-$(CONFIG_LZMA_DECOMPRESS) += lzma/
index 9a490f5bb68e186e2be47f28127f43853eed5bbe..fddcb3e4c6308e6b8f1a17ccb4472aeedf278ab2 100644 (file)
@@ -707,7 +707,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
                msleep(100);    /* Cool down */
 --- a/drivers/usb/core/message.c
 +++ b/drivers/usb/core/message.c
-@@ -1922,6 +1922,85 @@ free_interfaces:
+@@ -1924,6 +1924,85 @@ free_interfaces:
        if (cp->string == NULL &&
                        !(dev->quirks & USB_QUIRK_CONFIG_INTF_STRINGS))
                cp->string = usb_cache_string(dev, cp->desc.iConfiguration);
index 8c8a025f78f1c53bae70d9b1ef4d3cc14d47193a..31e7f2a2593b9d89a9fe99d9b15fc3a976626410 100644 (file)
@@ -244,7 +244,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
 +}
 --- a/fs/jffs2/super.c
 +++ b/fs/jffs2/super.c
-@@ -371,14 +371,41 @@ static int __init init_jffs2_fs(void)
+@@ -374,14 +374,41 @@ static int __init init_jffs2_fs(void)
        BUILD_BUG_ON(sizeof(struct jffs2_raw_inode) != 68);
        BUILD_BUG_ON(sizeof(struct jffs2_raw_summary) != 32);
  
@@ -1119,7 +1119,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
  ifdef CONFIG_FUNCTION_TRACER
  ORIG_CFLAGS := $(KBUILD_CFLAGS)
  KBUILD_CFLAGS = $(subst $(CC_FLAGS_FTRACE),,$(ORIG_CFLAGS))
-@@ -108,6 +118,8 @@ obj-$(CONFIG_LZ4HC_COMPRESS) += lz4/
+@@ -109,6 +119,8 @@ obj-$(CONFIG_LZ4HC_COMPRESS) += lz4/
  obj-$(CONFIG_LZ4_DECOMPRESS) += lz4/
  obj-$(CONFIG_XZ_DEC) += xz/
  obj-$(CONFIG_RAID6_PQ) += raid6/
index 13a544736d1500094c59755afef441209fe72926..018d0069295f36f6ffe74b947a826f54000f6a84 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3266,6 +3268,7 @@ static int packet_create(struct net *net
+@@ -3270,6 +3272,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3879,6 +3882,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3883,6 +3886,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3931,6 +3944,13 @@ static int packet_getsockopt(struct sock
+@@ -3935,6 +3948,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index e205ed057dde71b40e8067b0bd9d049867dfb83c..eb05632eb5f46defaee22735d5dc618e2a37f481 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include "gpiolib.h"
  
-@@ -539,3 +541,73 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -545,3 +547,73 @@ void of_gpiochip_remove(struct gpio_chip
        gpiochip_remove_pin_ranges(chip);
        of_node_put(chip->of_node);
  }
index 310104de7c04375df74cb9280e01e335e66e685a..953f02de6c6f83749d9b05d826515e5c154ddde0 100644 (file)
@@ -1710,7 +1710,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  #define BCSR5_INT_USB                 (0x02)
 --- a/include/linux/usb.h
 +++ b/include/linux/usb.h
-@@ -362,6 +362,7 @@ struct usb_bus {
+@@ -360,6 +360,7 @@ struct usb_bus {
                                         * for control transfers?
                                         */
        u8 otg_port;                    /* 0, or number of OTG/HNP port */
index 05806a98d01c4df887e668eacfaee608e52add6e..84eda53467bc645d09a65f89e48b180c2eae5077 100644 (file)
@@ -1086,7 +1086,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
  #define DRIVER_VERSION  "0.2"
  #define DRIVER_AUTHOR   "Alex Williamson <alex.williamson@redhat.com>"
-@@ -720,6 +722,27 @@ static void vfio_test_domain_fgsp(struct
+@@ -733,6 +735,27 @@ static void vfio_test_domain_fgsp(struct
        __free_pages(pages, order);
  }
  
@@ -1114,7 +1114,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static int vfio_iommu_type1_attach_group(void *iommu_data,
                                         struct iommu_group *iommu_group)
  {
-@@ -728,6 +751,8 @@ static int vfio_iommu_type1_attach_group
+@@ -741,6 +764,8 @@ static int vfio_iommu_type1_attach_group
        struct vfio_domain *domain, *d;
        struct bus_type *bus = NULL;
        int ret;
@@ -1123,7 +1123,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        mutex_lock(&iommu->lock);
  
-@@ -774,11 +799,15 @@ static int vfio_iommu_type1_attach_group
+@@ -787,11 +812,15 @@ static int vfio_iommu_type1_attach_group
        if (ret)
                goto out_domain;
  
@@ -1141,7 +1141,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                pr_warn("%s: No interrupt remapping support.  Use the module param \"allow_unsafe_interrupts\" to enable VFIO IOMMU support on this platform\n",
                       __func__);
                ret = -EPERM;
-@@ -820,6 +849,12 @@ static int vfio_iommu_type1_attach_group
+@@ -833,6 +862,12 @@ static int vfio_iommu_type1_attach_group
        if (ret)
                goto out_detach;