toolchain/glibc: update to latest 2.26 commit
authorHans Dedecker <dedeckeh@gmail.com>
Thu, 13 Sep 2018 07:26:44 +0000 (09:26 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 13 Sep 2018 09:11:53 +0000 (11:11 +0200)
c5c90b480e Fix segfault in maybe_script_execute.
174709d879 pthread_cond_broadcast: Fix waiters-after-spinning case [BZ #23538]
c9570bd2f5 x86: Populate COMMON_CPUID_INDEX_80000001 for Intel CPUs [BZ #23459]
86e0996b1a x86: Correct index_cpu_LZCNT [BZ #23456]
cf6deb084b conform/conformtest.pl: Escape literal braces in regular expressions
b12bed3e06 stdio-common/tst-printf.c: Remove part under a non-free license [BZ #23363]
20dc7a909a libio: Add tst-vtables, tst-vtables-interposed
4b10e69b1f Synchronize support/ infrastructure with master
762e9d63d5 NEWS: Reorder out-of-order bugs
2781bd5a86 libio: Disable vtable validation in case of interposition [BZ #23313]
74d16a57a3 Check length of ifname before copying it into to ifreq structure.
3aaf8bda00 getifaddrs: Don't return ifa entries with NULL names [BZ #21812]
f958b45d52 Use _STRUCT_TIMESPEC as guard in <bits/types/struct_timespec.h> [BZ #23349]
81b994bd83 Fix parameter type in C++ version of iseqsig (bug 23171)
7b52c8ae05 libio: Avoid _allocate_buffer, _free_buffer function pointers [BZ #23236]
4df8479e6b Add NEWS entry for CVE-2018-11236
a5bc5ec967 Add references to CVE-2018-11236, CVE-2017-18269
58ad5f8a64 Add a test case for [BZ #23196]
6b4362f2cb Don't write beyond destination in __mempcpy_avx512_no_vzeroupper (bug 23196)

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
toolchain/glibc/common.mk

index 2de9596dcf32f9100abf9103d0e1ce92b435d395..a741bf84b29fa2389bdd418516faed6cd798ae8a 100644 (file)
@@ -11,8 +11,8 @@ PKG_VERSION:=2.26
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=af7519f7b35024224c163e32a89fb247b0c446fc
-PKG_MIRROR_HASH:=7f4d0b9d55b5820b9e2feefed03206086b3d1ddef5f02358e587948f5bb9c516
+PKG_SOURCE_VERSION:=c5c90b480e4f21ed1d28e0e6d942b06b8d9e8bd7
+PKG_MIRROR_HASH:=f8e81f714fb5df5b142c0004d69aba87fc73235cffb86b1b1837e993e910bc13
 PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz