kernel: bump 4.14 to 4.14.126
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 17 Jun 2019 10:37:18 +0000 (12:37 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 18 Jun 2019 09:44:19 +0000 (11:44 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/pending-4.14/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch

index fe096508e22149f76e9a32916ba4a0f54352ef3a..1e69659825c3fa60f2df839e8d987027f60cee49 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .181
-LINUX_VERSION-4.14 = .125
+LINUX_VERSION-4.14 = .126
 
 LINUX_KERNEL_HASH-4.9.181 = 8fcd223e11cba322801bc38cdb8b581d64c0115f585dcb6604de8561b574fced
-LINUX_KERNEL_HASH-4.14.125 = 3e3dbc20215a28385bf46e2d0b8d9019df38ef1ee677e5e8870c7c3cde2ab318
+LINUX_KERNEL_HASH-4.14.126 = 6a2e89504d8560b132ab743a0206ffce026bff2697b705819421c5f125633970
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 61ececbc896e900cb13d0e34d41e1e10fa7152f1..3308b1d71f98ca7044caea9c7b1a8feb0bbac013 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -6143,7 +6143,7 @@ static void __ref alloc_node_mem_map(str
+@@ -6145,7 +6145,7 @@ static void __ref alloc_node_mem_map(str
                mem_map = NODE_DATA(0)->node_mem_map;
  #if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)