kernel: bump 4.9 to 4.9.179
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 28 May 2019 09:34:33 +0000 (11:34 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 3 Jun 2019 10:43:17 +0000 (12:43 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/pending-4.9/810-pci_disable_common_quirks.patch
target/linux/lantiq/patches-4.9/0001-MIPS-lantiq-add-pcie-driver.patch
target/linux/layerscape/patches-4.9/702-pci-support-layerscape.patch

index 9c3bd9c5b37f5493656959eb500a52da402d1784..bd54e7160aaa72f197e755fe6e96ec467656b053 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .178
+LINUX_VERSION-4.9 = .179
 LINUX_VERSION-4.14 = .121
 
-LINUX_KERNEL_HASH-4.9.178 = 13ffd8b0725d9ce9f9e927f4748ef640b049d7c69f21b28ca0d976cc23072566
+LINUX_KERNEL_HASH-4.9.179 = 532e4b7b0103806dad9124fd09d15d19594eca08e7f900e94ff805d3b4171ee3
 LINUX_KERNEL_HASH-4.14.121 = 2eecd6825a0998c8b6dd686cd4cd76e9f0d195bbace89f0b82495cc11ddb2884
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index f730e83878ee502af7b5dd6e4a6ea6397e4792bd..6130ac86a9f89ac4cacca7f906c8edb53d224694 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  /* The Mellanox Tavor device gives false positive parity errors
   * Mark this device with a broken_parity_status, to allow
   * PCI scanning code to "skip" this now blacklisted device.
-@@ -3038,6 +3039,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
+@@ -3055,6 +3056,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65f9, quirk_intel_mc_errata);
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x65fa, quirk_intel_mc_errata);
  
@@ -40,7 +40,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  /*
   * Ivytown NTB BAR sizes are misreported by the hardware due to an erratum.  To
-@@ -3094,6 +3096,8 @@ static void fixup_debug_report(struct pc
+@@ -3111,6 +3113,8 @@ static void fixup_debug_report(struct pc
        }
  }
  
@@ -49,7 +49,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  /*
   * Some BIOS implementations leave the Intel GPU interrupts enabled,
   * even though no one is handling them (f.e. i915 driver is never loaded).
-@@ -3132,6 +3136,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
+@@ -3149,6 +3153,8 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_IN
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x010a, disable_igfx_irq);
  DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_INTEL, 0x0152, disable_igfx_irq);
  
index c78f6c60312caeba4584e14cc8ec05d7a01883be..c4105b58b51b8bc6769211d919eff9e334449f1e 100644 (file)
@@ -5494,7 +5494,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
          (transaction layer end-to-end CRC checking).
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1252,6 +1252,8 @@ void pci_walk_bus(struct pci_bus *top, i
+@@ -1254,6 +1254,8 @@ void pci_walk_bus(struct pci_bus *top, i
                  void *userdata);
  int pci_cfg_space_size(struct pci_dev *dev);
  unsigned char pci_bus_max_busnr(struct pci_bus *bus);
index 03c3fb7cb98430df44c64f15b1e4ca1a733629c0..a51086f603f7992a4d9832af495f089f221998c3 100644 (file)
@@ -2060,7 +2060,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        }
 --- a/drivers/pci/quirks.c
 +++ b/drivers/pci/quirks.c
-@@ -4679,3 +4679,11 @@ DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_IN
+@@ -4697,3 +4697,11 @@ DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_IN
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2031, quirk_no_aersid);
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2032, quirk_no_aersid);
  DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_INTEL, 0x2033, quirk_no_aersid);
@@ -2074,7 +2074,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 +DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_FREESCALE, PCI_ANY_ID, quirk_fsl_no_msi);
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1825,6 +1825,7 @@ void pcibios_release_device(struct pci_d
+@@ -1827,6 +1827,7 @@ void pcibios_release_device(struct pci_d
  void pcibios_penalize_isa_irq(int irq, int active);
  int pcibios_alloc_irq(struct pci_dev *dev);
  void pcibios_free_irq(struct pci_dev *dev);