fstools: Install mount.hotplug and 10-fstab.defaults as 600
authorRosen Penev <rosenp@gmail.com>
Wed, 19 Sep 2018 01:32:20 +0000 (18:32 -0700)
committerRafał Miłecki <rafal@milecki.pl>
Thu, 10 Jan 2019 06:15:09 +0000 (07:15 +0100)
Both of these are used by programs that run as root and nothing else.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
[rmilecki: dropped PKG_SOURCE_URL regression from the original patch]
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
(cherry picked from commit 4ad87744fa83e2f75fd4f6e9a46f106aaf7ee2dc)

package/system/fstools/Makefile

index 440f187394732c6559a0ec4bee1da11704e4fe32..1b5bea47f06dee8dba27d98d363c6242ec886a6a 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/fstools.git
@@ -108,8 +108,8 @@ define Package/block-mount/install
        $(INSTALL_DIR) $(1)/sbin $(1)/lib $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
 
        $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
-       $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
-       $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
+       $(INSTALL_CONF) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
+       $(INSTALL_CONF) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libblkid-tiny.so $(1)/lib/