projects
/
oweals
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8af6497
)
build: use busybox gzip compatible force option
author
Mathew McBride
<matt@traverse.com.au>
Wed, 28 Mar 2018 02:34:52 +0000
(13:34 +1100)
committer
John Crispin
<john@phrozen.org>
Mon, 18 Jun 2018 19:31:30 +0000
(21:31 +0200)
commit
138c763
("build: add --force option to gzip in Build/gzip")
added the --force flag to the gzip invocation.
Under environments with busybox gzip (e.g Alpine Linux), this fails
as busybox only recognizes "-f".
Signed-off-by: Mathew McBride <matt@traverse.com.au>
(cherry picked from commit
fba168f5745acac95db519a9984b62e3e508df6a
)
include/image-commands.mk
patch
|
blob
|
history
diff --git
a/include/image-commands.mk
b/include/image-commands.mk
index 1d8ccedd693a7fc857ec2204e3f1d6194c167b78..4d3f025b123f44cfd48d5b6cf081ae7633577277 100644
(file)
--- a/
include/image-commands.mk
+++ b/
include/image-commands.mk
@@
-135,7
+135,7
@@
define Build/lzma-no-dict
endef
define Build/gzip
- gzip -
-force
-9n -c $@ $(1) > $@.new
+ gzip -
f
-9n -c $@ $(1) > $@.new
@mv $@.new $@
endef