projects
/
oweals
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cfb5a55
)
toolchain: add musl libc.so to external toolchain
author
Hauke Mehrtens
<hauke.mehrtens@intel.com>
Tue, 14 Mar 2017 18:18:57 +0000
(19:18 +0100)
committer
Jo-Philipp Wich
<jo@mein.io>
Wed, 13 Dec 2017 13:44:24 +0000
(14:44 +0100)
musl provides a /lib/libc.so file which should be integrated into the libc
package when the external toolchain with musl is used.
Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Reviewed-by: Florian Fainelli <f.fainelli@gmail.com>
Acked-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit
b6a8b43dd2771d4d237256417218bed862545ef4
)
package/libs/toolchain/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/toolchain/Makefile
b/package/libs/toolchain/Makefile
index 88adb9a8a4158ff38452760cfd52875880c6a3ad..58bd06cb5aba92f8d42f293ee978bddee90de215 100644
(file)
--- a/
package/libs/toolchain/Makefile
+++ b/
package/libs/toolchain/Makefile
@@
-164,7
+164,7
@@
define Package/libc/config
string
prompt "libc shared library files (use wildcards)"
depends on EXTERNAL_TOOLCHAIN && PACKAGE_libc
- default "./lib/ld{*.so*,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*}"
+ default "./lib/ld{*.so*,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*
,.so
}"
endmenu
endef