move modules.d stuff in /etc/init.d/S10boot and make it more like /etc/modules
authorFelix Fietkau <nbd@openwrt.org>
Thu, 21 Apr 2005 22:19:21 +0000 (22:19 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 21 Apr 2005 22:19:21 +0000 (22:19 +0000)
SVN-Revision: 703

openwrt/package/openwrt/Makefile
openwrt/target/default/target_skeleton/etc/init.d/S10boot

index 01c830dc4ac6502d2ce551059c68a889dce77af1..ea2bfd85865925ba464ac5654711ffa67d1b5ce4 100644 (file)
@@ -84,7 +84,7 @@ $(PKG_BUILD_DIR)/wlcompat-debug.o:
 $(PKG_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o
        $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_BUILD_DIR)/wlcompat kmod-wlcompat.control $(LINUX_VERSION)-$(PKG_RELEASE) $(ARCH)
        mkdir -p $(PKG_BUILD_DIR)/wlcompat/etc/modules.d
-       echo "insmod wlcompat" > $(PKG_BUILD_DIR)/wlcompat/etc/modules.d/10-wlcompat
+       echo "wlcompat" > $(PKG_BUILD_DIR)/wlcompat/etc/modules.d/10-wlcompat
        mkdir -p $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)
        cp $^ $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)/
        $(IPKG_BUILD) $(PKG_BUILD_DIR)/wlcompat $(PACKAGE_DIR)
index 990480798ba1c58744ef1341baa0d1e859f46e1e..47a255dd0f31a1715e28fafd9e0bfb4ddd5b3460 100755 (executable)
@@ -25,7 +25,7 @@ touch /var/log/lastlog
   }
 }
 
-sed 's/^[^#]/insmod &/' /etc/modules 2>&-|ash
+cat /etc/modules /etc/modules.d/* | sed 's/^[^#]/insmod &/' 2>&-|ash
 
 ifconfig lo 127.0.0.1 up
 ifconfig eth0 promisc