ath79: image: add supported string for routerstations and ja76pf2
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Fri, 23 Aug 2019 13:50:50 +0000 (15:50 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 29 Sep 2019 09:31:20 +0000 (11:31 +0200)
Now that the md5 check is fixed and metadata present, sysupgrade on
ar71xx will complain about device not being supported by the image.
Since the cause is not matching strings for supported devices add them
accordingly.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
(cherry picked from commit a45cf75eca4069f24bf5bba8f245de2e553f7f78)

target/linux/ath79/image/generic-ubnt.mk
target/linux/ath79/image/generic.mk

index f9f74d0f51986bdf9b2f82c982a4b53e8ae5feb6..ac3b935900218c498fec45adb2a05ccdfd725ad2 100644 (file)
@@ -218,6 +218,7 @@ define Device/ubnt_routerstation
   UBNT_TYPE := RSx
   UBNT_CHIP := ar7100
   DEVICE_PACKAGES += -swconfig
+  SUPPORTED_DEVICES += routerstation
 endef
 TARGET_DEVICES += ubnt_routerstation
 
@@ -227,6 +228,7 @@ define Device/ubnt_routerstation-pro
   UBNT_BOARD := RSPRO
   UBNT_TYPE := RSPRO
   UBNT_CHIP := ar7100pro
+  SUPPORTED_DEVICES += routerstation-pro
 endef
 TARGET_DEVICES += ubnt_routerstation-pro
 
index a2b82cbf7fe909d4c73e9a34cd4b71fbbef2809e..3b7fdb7015fe753be5cf748cd0b78208f2030e30 100644 (file)
@@ -479,6 +479,7 @@ define Device/jjplus_ja76pf2
   KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
   KERNEL_INITRAMFS := kernel-bin | append-dtb
   IMAGE_SIZE := 16000k
+  SUPPORTED_DEVICES += ja76pf2
 endef
 TARGET_DEVICES += jjplus_ja76pf2