kernel: bump 4.9 to 4.9.188
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 7 Aug 2019 11:54:26 +0000 (13:54 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 9 Aug 2019 16:34:08 +0000 (18:34 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/011-kbuild-export-SUBARCH.patch
target/linux/generic/hack-4.9/202-reduce_module_size.patch
target/linux/generic/hack-4.9/207-disable-modorder.patch
target/linux/generic/hack-4.9/220-gc_sections.patch
target/linux/generic/pending-4.9/201-extra_optimization.patch
target/linux/lantiq/patches-4.9/0050-MIPS-Lantiq-Fix-cascaded-IRQ-setup.patch
target/linux/layerscape/patches-4.9/302-dts-support-layercape.patch

index e6039e5a910bff3857e8d13d793200190977ae7e..cd3ddecf8420fc24d38fa0217f099dd11276daac 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .187
+LINUX_VERSION-4.9 = .188
 LINUX_VERSION-4.14 = .136
 
-LINUX_KERNEL_HASH-4.9.187 = 014bcd042cd25e073539c17bd34c616a936b19787a9c6a4c35d36a4f28afd1c7
+LINUX_KERNEL_HASH-4.9.188 = 27539853b25d1830fe81b108f39249c6ddf8b47257cdba09404ba0949863e222
 LINUX_KERNEL_HASH-4.14.136 = 268dff959216e59437a8f9db7c2cea3a1ada8a4c72232dc5b7f83ecca12bdf70
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 6ef95db8dd0444f96977a0eb704973fd57b821ee..4c0e07581dcfb97ff12538a6b28080d6b47e1d58 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -406,8 +406,8 @@ KERNELRELEASE = $(shell cat include/conf
+@@ -407,8 +407,8 @@ KERNELRELEASE = $(shell cat include/conf
  KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
  
  export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
index a9f97a69d801ca69b2c99e88f7a946399296cf54..e4863867772c7899b35a3be7a8d0caeb881aad94 100644 (file)
@@ -20,5 +20,5 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 -KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
 +KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
  GCC_PLUGINS_CFLAGS :=
+ CLANG_FLAGS :=
  
- # Read KERNELRELEASE from include/config/kernel.release (if it exists)
index c66a4db200079949c843ab0f7362fcb8bc0c487e..f03c62e025353c0c4864bca20077523bf8afb513 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1227,7 +1227,6 @@ all: modules
+@@ -1228,7 +1228,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1257,7 +1256,6 @@ _modinst_:
+@@ -1258,7 +1257,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index 1baa1bf21fd48fcd282f1b7b48e1cf1c9a610544..e795d666dfbf0dc678bd0e2c5ef28393f171f757 100644 (file)
@@ -21,9 +21,9 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -401,6 +401,11 @@ KBUILD_CFLAGS_MODULE  := -DMODULE
- KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
+@@ -402,6 +402,11 @@ KBUILD_LDFLAGS_MODULE = -T $(srctree)/sc
  GCC_PLUGINS_CFLAGS :=
+ CLANG_FLAGS :=
  
 +ifdef CONFIG_LD_DEAD_CODE_DATA_ELIMINATION
 +KBUILD_CFLAGS_KERNEL  += $(call cc-option,-ffunction-sections,)
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
  KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
  KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -651,11 +656,6 @@ KBUILD_CFLAGS     += $(call cc-disable-warni
+@@ -652,11 +657,6 @@ KBUILD_CFLAGS     += $(call cc-disable-warni
  KBUILD_CFLAGS += $(call cc-disable-warning, address-of-packed-member)
  KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
  
index f5ff7081ee6b4ffce82573271b32ae2db7a67b26..813951158cbc7f7d4432aad6a9904c3941533816 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -657,12 +657,12 @@ KBUILD_CFLAGS    += $(call cc-option,-fdata
+@@ -658,12 +658,12 @@ KBUILD_CFLAGS    += $(call cc-option,-fdata
  endif
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
index c0d7afc5412a51148da95c38b4f55a339404fc37..4382aec204d66df32f65ffce086fae900dc88a0f 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/arch/mips/lantiq/irq.c
 +++ b/arch/mips/lantiq/irq.c
-@@ -271,6 +271,11 @@ static void ltq_hw5_irqdispatch(void)
+@@ -272,6 +272,11 @@ static void ltq_hw5_irqdispatch(void)
  DEFINE_HWx_IRQDISPATCH(5)
  #endif
  
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #ifdef CONFIG_MIPS_MT_SMP
  void __init arch_init_ipiirq(int irq, struct irqaction *action)
  {
-@@ -315,23 +320,19 @@ static struct irqaction irq_call = {
+@@ -316,23 +321,19 @@ static struct irqaction irq_call = {
  asmlinkage void plat_irq_dispatch(void)
  {
        unsigned int pending = read_c0_status() & read_c0_cause() & ST0_IM;
@@ -64,7 +64,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  static int icu_map(struct irq_domain *d, unsigned int irq, irq_hw_number_t hw)
-@@ -356,11 +357,6 @@ static const struct irq_domain_ops irq_d
+@@ -357,11 +358,6 @@ static const struct irq_domain_ops irq_d
        .map = icu_map,
  };
  
@@ -76,7 +76,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  int __init icu_of_init(struct device_node *node, struct device_node *parent)
  {
        struct device_node *eiu_node;
-@@ -392,7 +388,7 @@ int __init icu_of_init(struct device_nod
+@@ -393,7 +389,7 @@ int __init icu_of_init(struct device_nod
        mips_cpu_irq_init();
  
        for (i = 0; i < MAX_IM; i++)
index 37dc5ee5f0cfdc6efaf6c8f1f7ee282e26db498d..8fa89f776f664a3cc7132f5013d5fc7a88bce5b4 100644 (file)
@@ -738,7 +738,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                };
 --- a/arch/arm/boot/dts/rk3288.dtsi
 +++ b/arch/arm/boot/dts/rk3288.dtsi
-@@ -1109,7 +1109,7 @@
+@@ -1110,7 +1110,7 @@
                #address-cells = <0>;
  
                reg = <0xffc01000 0x1000>,