ath79: fix remaining IMAGE_SIZE issues
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 22 Oct 2019 11:08:25 +0000 (13:08 +0200)
committerJohn Crispin <john@phrozen.org>
Sun, 27 Oct 2019 13:03:03 +0000 (14:03 +0100)
This fixes the remaining IMAGE_SIZE issues in ath79 target.
All devices in target have been checked, so together with
previous patches this target should be "clean" afterwards.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/generic.mk
target/linux/ath79/image/tiny-tp-link.mk

index 3373956e4566c61a2a762af10c1fbbb94dc69d59..cea903f2534439d4b5eee690716ff4c6f995f86e 100644 (file)
@@ -199,7 +199,7 @@ define Device/buffalo_wzr-hp-ag300h
   ATH_SOC := ar7161
   DEVICE_VENDOR := Buffalo
   DEVICE_MODEL := WZR-HP-AG300H
-  IMAGE_SIZE := 32256k
+  IMAGE_SIZE := 32320k
   IMAGES += factory.bin tftp.bin
   IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
   IMAGE/factory.bin := $$(IMAGE/default) | buffalo-enc WZR-HP-AG300H 1.99 | buffalo-tag WZR-HP-AG300H 3
index b6b085fc9301879debab6648065122099e7ea9b3..3d1b26d17f399c7fb0c8368906f176f9abb98235 100644 (file)
@@ -12,6 +12,7 @@ TARGET_DEVICES += tplink_tl-mr10u
 
 define Device/tplink_tl-mr3020-v1
   $(Device/tplink-4mlzma)
+  IMAGE_SIZE := 3840k
   ATH_SOC := ar9331
   DEVICE_MODEL := TL-MR3020
   DEVICE_VARIANT := v1