kernel: bump 4.9 to 4.9.163
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 14 Mar 2019 13:23:25 +0000 (14:23 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 19 Mar 2019 15:30:29 +0000 (16:30 +0100)
Refreshed all targets.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch

index 228f4301520bbb88e68ff4e8197d57294607a810..d746466d18c2c3a5d789263b57bc4cf175e1b764 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .162
+LINUX_VERSION-4.9 = .163
 LINUX_VERSION-4.14 = .105
 
-LINUX_KERNEL_HASH-4.9.162 = b946f44edcc4e1b1ccf51ce17dd8f494556555b31b0663bbaabfad99100dacd5
+LINUX_KERNEL_HASH-4.9.163 = c27cf9962c17b91275ab9e74b43c1269f726f79e7a85421be7c5c73d267eef91
 LINUX_KERNEL_HASH-4.14.105 = 398bdb98b4e4d0ad0e60f4fa530f3f8451ef8dafdf512b7754aa29953263f6e9
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 225e956e61c604263905c3567484b62f19bedc0e..dc97edfdc540dd3e99af6ae7ac6611522bc9be65 100644 (file)
@@ -399,7 +399,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                        /* bnx2x_has_rx_work() reads the status block,
 --- a/drivers/net/ethernet/broadcom/bnxt/bnxt.c
 +++ b/drivers/net/ethernet/broadcom/bnxt/bnxt.c
-@@ -1781,7 +1781,7 @@ static int bnxt_poll_nitroa0(struct napi
+@@ -1787,7 +1787,7 @@ static int bnxt_poll_nitroa0(struct napi
        }
  
        if (!bnxt_has_work(bp, cpr) && rx_pkts < budget) {
index deaca743dd48224f974423c9be2833c27c1246e0..2fc47b614ee55f066cb2eecf4cd874822be482f0 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        return entry->group;
  }
-@@ -3173,9 +3175,10 @@ static bool amd_iommu_capable(enum iommu
+@@ -3180,9 +3182,10 @@ static bool amd_iommu_capable(enum iommu
        return false;
  }
  
@@ -47,7 +47,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        struct unity_map_entry *entry;
        int devid;
  
-@@ -3184,41 +3187,56 @@ static void amd_iommu_get_dm_regions(str
+@@ -3191,41 +3194,56 @@ static void amd_iommu_get_dm_regions(str
                return;
  
        list_for_each_entry(entry, &amd_iommu_unity_map, list) {
@@ -118,7 +118,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        struct dma_ops_domain *dma_dom = to_dma_ops_domain(to_pdomain(domain));
        unsigned long start, end;
-@@ -3242,9 +3260,9 @@ static const struct iommu_ops amd_iommu_
+@@ -3249,9 +3267,9 @@ static const struct iommu_ops amd_iommu_
        .add_device = amd_iommu_add_device,
        .remove_device = amd_iommu_remove_device,
        .device_group = amd_iommu_device_group,