projects
/
oweals
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9885d3a
)
kernel: add missing dependency to regmap to kmod-gpio-mcp23s08
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 25 Aug 2018 16:11:03 +0000
(18:11 +0200)
committer
Jo-Philipp Wich
<jo@mein.io>
Tue, 18 Dec 2018 16:22:03 +0000
(17:22 +0100)
This fixes a build problem recently introduced.
Fixes:
a904003b9b5f
("kernel: fix kmod-gpio-mcp23s08 for linux 4.14")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(backported from
e882e63f1e1169030389b304489ab8a7d785df33
)
package/kernel/linux/modules/other.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/other.mk
b/package/kernel/linux/modules/other.mk
index 9c3d54ebd89ca7c4080f0d7445c5b8d704816363..ecf222ac138fab66f323c1bd936ae2bde45def21 100644
(file)
--- a/
package/kernel/linux/modules/other.mk
+++ b/
package/kernel/linux/modules/other.mk
@@
-227,7
+227,7
@@
$(eval $(call KernelPackage,gpio-dev))
define KernelPackage/gpio-mcp23s08
SUBMENU:=$(OTHER_MENU)
TITLE:=Microchip MCP23xxx I/O expander
- DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+ DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+LINUX_4_14:kmod-regmap
KCONFIG:= \
CONFIG_GPIO_MCP23S08 \
CONFIG_PINCTRL_MCP23S08