x86: make profile titles more verbose
authorPaul Spooren <mail@aparcar.org>
Wed, 31 Jul 2019 14:34:38 +0000 (16:34 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 2 Nov 2019 23:30:09 +0000 (00:30 +0100)
So far (nearly) all x86 profiles are called "Generic" which makes
it hard to distinguish them in special cases, like searching for a
specific profile (without pre-selecting target/subtarget).

To make this change locally working, remove the tmp/ folder to
force reload of menuconfig.

As these files are infrequently touched, the Copyright was updated
as well.

Signed-off-by: Paul Spooren <mail@aparcar.org>
[changed commit title]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/x86/64/Makefile [new file with mode: 0644]
target/linux/x86/64/profiles/000-Generic.mk
target/linux/x86/generic/profiles/000-Generic.mk
target/linux/x86/geode/profiles/000-Generic.mk
target/linux/x86/geode/profiles/100-Geos.mk
target/linux/x86/legacy/profiles/000-Generic.mk

diff --git a/target/linux/x86/64/Makefile b/target/linux/x86/64/Makefile
new file mode 100644 (file)
index 0000000..e69de29
index ccd125afa2797af9ceeec50e5440151edf15cf34..b5b10c4adecc978c61b0788000b367bf51799f83 100644 (file)
@@ -1,15 +1,15 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Generic
-  NAME:=Generic
+  NAME:=Generic x86/64
 endef
 
 define Profile/Generic/Description
-       Generic Profile
+       Generic Profile for x86/64 architecture
 endef
 $(eval $(call Profile,Generic))
index 4760767eee14c022d5c7c3ad5b51c1162dcc5004..7717131be07b355a9643e4878f568927d9d2df1b 100644 (file)
@@ -1,12 +1,12 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Generic
-  NAME:=Generic
+  NAME:=Generic x86
   PACKAGES:=kmod-e1000e kmod-igb kmod-bnx2 \
        kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
        kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
@@ -14,6 +14,6 @@ define Profile/Generic
 endef
 
 define Profile/Generic/Description
-       Generic Profile
+       Generic Profile for x86 architecture
 endef
 $(eval $(call Profile,Generic))
index 58dc3c641c241fe1929b690b92df956c490f2bce..be11b33e9718ec79113e61dc2b99f7ee3a29d6f6 100644 (file)
@@ -1,12 +1,12 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Generic
-  NAME:=Generic
+  NAME:=Generic x86/Geode
   PACKAGES:= \
                soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
                hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
index 94e501edf4917d707199bd102cf5ca7afba546e0..f51e892cbf217ef1dc66728569b050560c0217c0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 90f989a91de33164339f1d25aa574a18a337c5ff..566a66c1bef2c31a928901d83a8e19c9ff84989e 100644 (file)
@@ -1,18 +1,18 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2019 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Generic
-  NAME:=Generic
+  NAME:=Generic x86/legacy
   PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
        kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
        kmod-via-rhine kmod-via-velocity
 endef
 
 define Profile/Generic/Description
-       Generic Profile
+       Generic Profile for x86 legacy architecutre
 endef
 $(eval $(call Profile,Generic))