use HOST_STATIC_LINKING instead of hardcoding -static
[oweals/openwrt.git] / tools / sdcc / Makefile
index ef75fca9acd2589c1d2c6ecefcc64d8c893dfb6d..3210bb3e763791e7f8d044918d70e862b319a4a3 100644 (file)
@@ -17,6 +17,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 HOST_CONFIGURE_ARGS += \
        --disable-ucsim \
        --enable-packihx \