use HOST_STATIC_LINKING instead of hardcoding -static
[oweals/openwrt.git] / tools / sdcc / Makefile
index 1e827a6091404446026cd12f3118f067ef498be4..3210bb3e763791e7f8d044918d70e862b319a4a3 100644 (file)
@@ -17,10 +17,11 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 HOST_CONFIGURE_ARGS += \
        --disable-ucsim \
-       --disable-packihx \
-       --disable-sdcpp \
+       --enable-packihx \
+       --enable-sdcpp \
        --disable-sdcdb \
        --disable-gbz80-port \
        --disable-z80-port \