tools/zlib: move zlib build to tools
[oweals/openwrt.git] / tools / make-ext4fs / patches / 100-add-ldflags.patch
diff --git a/tools/make-ext4fs/patches/100-add-ldflags.patch b/tools/make-ext4fs/patches/100-add-ldflags.patch
new file mode 100644 (file)
index 0000000..d9ce47b
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -27,7 +27,7 @@ OBJ := \
+       $(CC) $(CFLAGS) -c -o $@ $^
+ make_ext4fs: $(OBJ) libsparse/libsparse.a
+-      $(CC) -o $@ $^ $(ZLIB)
++      $(CC) $(LDFLAGS)-o $@ $^ $(ZLIB)
+ libsparse/libsparse.a:
+       $(MAKE) -C libsparse/ libsparse.a