firmware-utils: ptgen: add GPT support
[oweals/openwrt.git] / tools / flex / Makefile
index f170be53da84ec134451e998f46e8623ee200a03..bb5aecbdfeadeef0f3803c6e9678b1de5a31978e 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2008-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -7,18 +7,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
-PKG_VERSION:=2.6.3
+PKG_CPE_ID:=cpe:/a:flex_project:flex
+PKG_VERSION:=2.6.4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/westes/flex/releases/download/v$(PKG_VERSION)/
-PKG_HASH:=68b2742233e747c462f781462a2a1e299dc6207401dac8f0bbb316f48565c2aa
+PKG_HASH:=e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995
 
+HOST_FIXUP:=autoreconf
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(LN) flex $(STAGING_DIR_HOST)/bin/lex
+endef
+
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)