tools/patch: apply upstream patch for cve-2019-13638
[oweals/openwrt.git] / tools / bison / Makefile
index 8cc787148dad9bc17d63cd1bc2bc02d9bb2484c5..45255da4fb17c840375bec0be51272962117fc1d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008-2012 OpenWrt.org
+#
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,18 +7,26 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
-PKG_VERSION:=2.5
+PKG_VERSION:=3.4.1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=9dba20116b13fc61a0846b0058fbe004
-PKG_CAT:=bzcat
+PKG_HASH:=27159ac5ebf736dffd5636fd2cd625767c9e437de65baa63cb0de83570bd820d
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += --enable-threads=pth
+
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
 $(eval $(call HostBuild))