upgrade to gcc 4.4.7
[oweals/openwrt.git] / toolchain / gcc / common.mk
index 73d63ba9a28f1a7b908b7bd4d193b7e5521a4bc9..c0bc3f8c5da1a3621e71a4113b95e5ab8e457485 100644 (file)
@@ -57,12 +57,15 @@ else
   PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
-  ifeq ($(PKG_VERSION),4.4.6)
-    PKG_MD5SUM:=ab525d429ee4425050a554bc9247d6c4
+  ifeq ($(PKG_VERSION),4.4.7)
+    PKG_MD5SUM:=295709feb4441b04e87dea3f1bab4281
   endif
   ifeq ($(PKG_VERSION),4.6.2)
     PKG_MD5SUM:=028115c4fbfb6cfd75d6369f4a90d87e
   endif
+  ifeq ($(PKG_VERSION),4.7.0)
+    PKG_MD5SUM:=2a0f1d99fda235c29d40b561f81d9a77
+  endif
 endif
 endif
 
@@ -155,10 +158,6 @@ else
                --enable-__cxa_atexit
 endif
 
-ifdef CONFIG_powerpc
-  TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
-endif
-
 ifneq ($(GCC_ARCH),)
   GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
 endif