zynq: remove kernel 4.14 support
[oweals/openwrt.git] / target / linux / zynq / patches-4.14 / 020-v4.17-add-digilent-zybo-z7-board.patch
diff --git a/target/linux/zynq/patches-4.14/020-v4.17-add-digilent-zybo-z7-board.patch b/target/linux/zynq/patches-4.14/020-v4.17-add-digilent-zybo-z7-board.patch
deleted file mode 100644 (file)
index 7ff31e3..0000000
+++ /dev/null
@@ -1,94 +0,0 @@
-From ba5c7a032c2ae66d5467820daab898e5f9048405 Mon Sep 17 00:00:00 2001
-From: Nobuhiro Iwamatsu <nobuhiro.iwamatsu@cybertrust.co.jp>
-Date: Wed, 28 Feb 2018 11:25:52 +0900
-Subject: [PATCH] arm: dts: zynq: Add Digilent Zybo Z7 board
-
-This add a DTS for the Digilent Zybo Z7 board.
-This board is the successor board of Zybo, these are almost the same except
-for ps-clk-frequency specifications.
-
-Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu@cybertrust.co.jp>
-Reviewed-by: Rob Herring <robh@kernel.org>
-Signed-off-by: Michal Simek <michal.simek@xilinx.com>
----
-Modifications:
-- Removed changes to file Documentation/devicetree/bindings/arm/xilinx.txt
----
- arch/arm/boot/dts/Makefile                    |  3 +-
- arch/arm/boot/dts/zynq-zybo-z7.dts            | 58 +++++++++++++++++++
- 2 files changed, 60 insertions(+), 1 deletion(-)
- create mode 100644 arch/arm/boot/dts/zynq-zybo-z7.dts
-
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -1006,7 +1006,8 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
-       zynq-zc702.dtb \
-       zynq-zc706.dtb \
-       zynq-zed.dtb \
--      zynq-zybo.dtb
-+      zynq-zybo.dtb \
-+      zynq-zybo-z7.dtb
- dtb-$(CONFIG_MACH_ARMADA_370) += \
-       armada-370-db.dtb \
-       armada-370-dlink-dns327l.dtb \
---- /dev/null
-+++ b/arch/arm/boot/dts/zynq-zybo-z7.dts
-@@ -0,0 +1,58 @@
-+// SPDX-License-Identifier: GPL-2.0+
-+/dts-v1/;
-+#include "zynq-7000.dtsi"
-+
-+/ {
-+      model = "Zynq ZYBO Z7 Development Board";
-+      compatible = "digilent,zynq-zybo-z7", "xlnx,zynq-7000";
-+
-+      aliases {
-+              ethernet0 = &gem0;
-+              serial0 = &uart1;
-+      };
-+
-+      memory@0 {
-+              device_type = "memory";
-+              reg = <0x0 0x20000000>;
-+      };
-+
-+      chosen {
-+              bootargs = "";
-+              stdout-path = "serial0:115200n8";
-+      };
-+
-+      usb_phy0: phy0 {
-+              #phy-cells = <0>;
-+              compatible = "usb-nop-xceiv";
-+              reset-gpios = <&gpio0 46 1>;
-+      };
-+};
-+
-+&clkc {
-+      ps-clk-frequency = <33333333>;
-+};
-+
-+&gem0 {
-+      status = "okay";
-+      phy-mode = "rgmii-id";
-+      phy-handle = <&ethernet_phy>;
-+
-+      ethernet_phy: ethernet-phy@0 {
-+              reg = <0>;
-+              device_type = "ethernet-phy";
-+      };
-+};
-+
-+&sdhci0 {
-+      status = "okay";
-+};
-+
-+&uart1 {
-+      status = "okay";
-+};
-+
-+&usb0 {
-+      status = "okay";
-+      dr_mode = "host";
-+      usb-phy = <&usb_phy0>;
-+};