x86: fix kmod-forcedeth package selection
[oweals/openwrt.git] / target / linux / x86 / generic / target.mk
index 5d384a1238d78bca63168761bd2b01ec3ef87f96..90586f56d6a730908964849fdc89e43d28e58861 100644 (file)
@@ -1,9 +1,11 @@
 BOARDNAME:=Generic
-
-LINUX_VERSION:=3.8.11
+CPU_TYPE :=pentium4
+FEATURES += audio pci pcie usb
+DEFAULT_PACKAGES += kmod-button-hotplug
 
 define Target/Description
-       Build firmware images for x86 based boards
-       (e.g : Soekris, ...)
+       Build firmware images for modern x86 based boards with CPUs
+       supporting at least the Intel Pentium 4 instruction set with
+       MMX, SSE and SSE2.
 endef