ar71xx: use DEFAULT:= in the uboot-ar71xx package instead of adding uboot to the...
[oweals/openwrt.git] / target / linux / x86 / Makefile
index 705cc84ad1e4938b07da69413817972a0755b1b0..8f11717a4e7ce4938acab094037071fd065f2c4f 100644 (file)
@@ -1,23 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
-
-LINUX_VERSION:=2.6.22.4
+FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+LINUX_VERSION:=2.6.32.33
 
-# include the profiles
--include profiles/*.mk
+include $(INCLUDE_DIR)/target.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))
 
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+       Please install mkisofs. \
+))