sysupgrade: fix typo in platform_do_upgrade() on x86 (closes: #7068), thanks to acinonyx
[oweals/openwrt.git] / target / linux / x86 / Makefile
index d1e459ce818df515a4f3108780493842d6a27933..4cf011af78a6d59195f0376d77006540e315c2c6 100644 (file)
@@ -1,20 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
+FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
+SUBTARGETS=generic olpc xen_domu ep80579
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.32.10
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))
 
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+       Please install mkisofs. \
+))