ar71xx: use DEFAULT:= in the uboot-ar71xx package instead of adding uboot to the...
[oweals/openwrt.git] / target / linux / rdc / Makefile
index 9099e783e58615c12d7c8d6b9c9bf0826302b244..e09642e202f1f71888ca0f96e3ea41eaf6f923a1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,12 @@ ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci usb pcmcia
-CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -funit-at-a-time
+CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -fno-caller-saves
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.33
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:=bzImage
-
 DEFAULT_PACKAGES += wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
                    kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
                    kmod-rdc321x-wdt