ar71xx: use DEFAULT:= in the uboot-ar71xx package instead of adding uboot to the...
[oweals/openwrt.git] / target / linux / rdc / Makefile
index 185b67a214aca62e549908b1a5b74e43aa0df8d4..e09642e202f1f71888ca0f96e3ea41eaf6f923a1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
-FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
+FEATURES:=squashfs jffs2 pci usb pcmcia
+CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -fno-caller-saves
 
-LINUX_VERSION:=2.6.28.10
+LINUX_VERSION:=2.6.32.33
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-rdc321x-wdt
+DEFAULT_PACKAGES += wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-rdc321x-wdt
 
 define Target/Description
         Build firmware images for RDC321x based routers