gemini: switch to 4.14
[oweals/openwrt.git] / target / linux / ramips / image / rt288x.mk
index e9627a7431b0a766ea3e2692688894f15e6e4342..c7f7d064fff42c46fac8cf8de6e2ae53b1f02a58 100644 (file)
@@ -30,7 +30,7 @@ define Device/ar725w
 endef
 TARGET_DEVICES += ar725w
 
-define Device/dap-1522-a1
+define Device/dlink_dap-1522-a1
   DTS := DAP-1522-A1
   BLOCKSIZE := 64k
   IMAGE_SIZE := 3801088
@@ -44,16 +44,14 @@ define Device/dap-1522-a1
        wrg-header wapnd01_dlink_dap1522 | \
        check-size $$$$(IMAGE_SIZE)
 endef
-TARGET_DEVICES += dap-1522-a1
+TARGET_DEVICES += dlink_dap-1522-a1
 
 define Device/f5d8235-v1
+  DTS := F5D8235_V1
   IMAGE_SIZE := 7744k
   DEVICE_TITLE := Belkin F5D8235 V1
   DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-core kmod-usb-ohci \
     kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
-  DEVICE_DTS := F5D8235_V1
-  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
-  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
 endef
 TARGET_DEVICES += f5d8235-v1