ramips: add support for TP-Link TL-WR840N v5
[oweals/openwrt.git] / target / linux / ramips / image / mt76x8.mk
index 56da7b104908e5f764e93ea5805c3a27e03f89d0..248f45eebd5fac6cedfccc93df1c9bf9525c262a 100644 (file)
@@ -99,6 +99,21 @@ define Device/tl-wr840n-v4
        check-size $$$$(IMAGE_SIZE)
 endef
 
+define Device/tl-wr840n-v5
+  DTS := TL-WR840NV5
+  IMAGE_SIZE := 3840k
+  DEVICE_TITLE := TP-Link TL-WR840N v5
+  TPLINK_FLASHLAYOUT := 4Mmtk
+  TPLINK_HWID := 0x08400005
+  TPLINK_HWREV := 0x1
+  TPLINK_HWREVADD := 0x5
+  TPLINK_HVERSION := 3
+  KERNEL := $(KERNEL_DTB)
+  KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v2-header -e
+  IMAGE/sysupgrade.bin := tplink-v2-image -s -e | append-metadata | \
+       check-size $$$$(IMAGE_SIZE)
+endef
+
 define Device/tl-wr841n-v13
   $(Device/tl-wr840n-v4)
   DTS := TL-WR841NV13
@@ -107,7 +122,7 @@ define Device/tl-wr841n-v13
   TPLINK_HWREV := 0x268
   TPLINK_HWREVADD := 0x13
 endef
-TARGET_DEVICES += tl-wr840n-v4 tl-wr841n-v13
+TARGET_DEVICES += tl-wr840n-v4 tl-wr840n-v5 tl-wr841n-v13
 
 define Device/vocore2
   DTS := VOCORE2