ramips: add support for UniElec U7628-01
[oweals/openwrt.git] / target / linux / ramips / image / mt7621.mk
index 779616292dabd9a2d21be0f1c254a578f53562d0..1dc5b1df3d7e1dc61848168e247f9d0b14b81829 100644 (file)
@@ -121,7 +121,7 @@ define Device/mir3g
   SUPPORTED_DEVICES += R3G
   DEVICE_PACKAGES := \
        kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini \
-       kmod-softdog
+       uboot-envtools
 endef
 TARGET_DEVICES += mir3g
 
@@ -225,6 +225,14 @@ define Device/timecloud
 endef
 TARGET_DEVICES += timecloud
 
+define Device/u7621-06-256M-16M
+  DTS := U7621-06-256M-16M
+  IMAGE_SIZE := 16064k
+  DEVICE_TITLE := UniElec U7621-06 (256M RAM/16M flash)
+  DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
+endef
+TARGET_DEVICES += u7621-06-256M-16M
+
 define Device/ubnt-erx
   DTS := UBNT-ERX
   FILESYSTEMS := squashfs