ramips: rt305x: add kernel support for the Planex MZK-W300NH2 Router
[oweals/openwrt.git] / target / linux / ramips / Makefile
index 7241be7485462b4492cf7fe969e2f102310ab9a8..ba00c926829f36fdb6205d4f35cff74af683a034 100644 (file)
@@ -10,10 +10,10 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.3.4
+LINUX_VERSION:=3.6.11
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\