kernel: mtdsplit: bcm_wfi: add sercomm support
[oweals/openwrt.git] / target / linux / ramips / Makefile
index fec7ddbc9319ec2a3c3c2e1d2e13a002bbc0e2c9..864cfa543d053b0991cb0fe0c029f18221419b00 100644 (file)
@@ -8,20 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt305x rt3883 mt7620a rt288x
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=mt7620 mt7621 mt76x8 rt288x rt305x rt3883
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.10.13
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini swconfig
+KERNEL_PATCHVER:=4.14
+KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += kmod-leds-gpio kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))