ramips: fix sdhci support on mt7621
[oweals/openwrt.git] / target / linux / ramips / Makefile
index 9d7bb5b6a806e65f517282a1b57e298d40705460..51cd8f3e06c706a2772af9fe9c75cb0d22c4f21b 100644 (file)
@@ -8,19 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
+BOARDNAME:=MediaTek Ralink MIPS
 SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
-FEATURES:=squashfs gpio
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+FEATURES:=squashfs gpio mips16
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=4.3
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+
 $(eval $(call BuildTarget))