kernel: remove kmod-crypto-aes, AES crypto support is always built into the kernel
[oweals/openwrt.git] / target / linux / ppc40x / Makefile
index cd64ea3f65d330a64c30665652f49481aacf80b8..fc85b03c2940bdf5e81ae6c859da1e3c33073ef5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=ppc40x
-BOARDNAME:=AMCC Kilauea
-FEATURES:=squashfs
+BOARDNAME:=AMCC/IBM PPC40x
+FEATURES:=squashfs broken
+CPU_TYPE:=405
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.24
-LINUX_KARCH:=powerpc
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Kilauea evaluation board
+       Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
+KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
+
 $(eval $(call BuildTarget))