ath79: add support for TP-Link TL-WA860RE v1
[oweals/openwrt.git] / target / linux / omap / Makefile
index f58197fdc941cde4ae765c5785f4ff9cb4a7893a..285677a60e78a7e2e78a7601221b014df75ff780 100644 (file)
@@ -4,18 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand squashfs
 CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 
-KERNEL_PATCHVER:=4.4
-
-MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
+KERNEL_PATCHVER:=4.19
 
 KERNELNAME:=zImage dtbs
 
@@ -25,6 +24,6 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))