octeon: apply vendor_model scheme to device definition/image name
[oweals/openwrt.git] / target / linux / octeon / image / Makefile
index 3d1bdf7b17ed6a34e2898849a406707a1517d2b8..e083e823c2211b2228c6f84cf3aae26422234ad5 100644 (file)
@@ -7,39 +7,44 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+define Build/strip-kernel
+       # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
+       $(TARGET_CROSS)strip -R .notes $@ -o $@.stripped && mv $@.stripped $@
+endef
+
 define Device/Default
   PROFILES = Default $$(DEVICE_NAME)
-  BOARD_NAME := $(BOARD)
   KERNEL_NAME := vmlinux.elf
   KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
   KERNEL := kernel-bin | strip-kernel | patch-cmdline
   IMAGES := sysupgrade.tar
-  IMAGE/sysupgrade.tar := sysupgrade-nand
-endef
-
-define Build/strip-kernel
-       # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
-       $(TARGET_CROSS)strip -R .notes $@ -o $@.stripped && mv $@.stripped $@
+  IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-extra 128k | sysupgrade-tar rootfs=$$$$@
+  IMAGE/sysupgrade.tar := sysupgrade-tar
 endef
 
 define Device/generic
+  DEVICE_VENDOR := Generic
+  DEVICE_MODEL := Octeon
   FILESYSTEMS := ext4
-  DEVICE_TITLE := Generic
 endef
 TARGET_DEVICES += generic
 
-ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro block2mtd.block2mtd=/dev/mmcblk0p2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
-define Device/er
-  CMDLINE := $(ER_CMDLINE) 
-  DEVICE_TITLE := Ubiquiti EdgeRouter
+ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
+define Device/ubnt_edgerouter
+  DEVICE_VENDOR := Ubiquiti
+  DEVICE_MODEL := EdgeRouter
+  BOARD_NAME := er
+  CMDLINE := $(ER_CMDLINE)
 endef
-TARGET_DEVICES += er
+TARGET_DEVICES += ubnt_edgerouter
 
-ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) block2mtd.block2mtd=/dev/sda2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
-define Device/erlite
-  CMDLINE := $(ERLITE_CMDLINE) 
-  DEVICE_TITLE := Ubiquiti EdgeRouter Lite
+ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
+define Device/ubnt_edgerouter-lite
+  DEVICE_VENDOR := Ubiquiti
+  DEVICE_MODEL := EdgeRouter Lite
+  BOARD_NAME := erlite
+  CMDLINE := $(ERLITE_CMDLINE)
 endef
-TARGET_DEVICES += erlite
+TARGET_DEVICES += ubnt_edgerouter-lite
 
 $(eval $(call BuildImage))