lantiq: unify Fritz!Box LED mappings
[oweals/openwrt.git] / target / linux / octeon / Makefile
index e1739e70e53ebab78df23f29181fba2046acbed3..aa73b0e5c044fedfa4208bae6a7097f0315cecce 100644 (file)
@@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 ext4 initramfs pci usb
-CPU_TYPE:=octeon
-CPU_CFLAGS_octeon:=-march=octeon -mabi=64
-MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-KERNEL_PATCHVER:=3.18
-
-include $(INCLUDE_DIR)/target.mk
+FEATURES:=squashfs ramdisk pci usb
+CPU_TYPE:=octeonplus
+MAINTAINER:=John Crispin <john@phrozen.org>
 
+KERNEL_PATCHVER:=4.19
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))