brcm47xx: use proper region code in image name
[oweals/openwrt.git] / target / linux / octeon / Makefile
index a196e94b5a4d0f014b37d0b089adb2b435a24a6b..254f22119fbf37efcb0e660da9ac41b8358d779b 100644 (file)
@@ -6,21 +6,21 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
+FEATURES:=squashfs ramdisk pci usb
 CPU_TYPE:=octeon
-CPU_CFLAGS_octeon:=-march=octeon
-MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-LINUX_VERSION:=3.10.28
-
-include $(INCLUDE_DIR)/target.mk
+MAINTAINER:=John Crispin <john@phrozen.org>
 
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))