mvebu: fix partition type and signature for sdcard
[oweals/openwrt.git] / target / linux / mvebu / image / Makefile
index 45ef45abdb90ef119159da2b3ed27b576522e810..a78269bf1fe02a294cd18dcc0fd4b70963228aa9 100644 (file)
@@ -13,8 +13,10 @@ include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR := 0x00008000
 
+SIGNATURE:=$(shell printf "%.8s" $(SOURCE_DATE_EPOCH))
+
 define Build/dtb
-        $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
+       $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
 endef
 
 # SD-Card Images:
@@ -43,6 +45,7 @@ endef
 
 define Build/sdcard-img
        ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
+       SIGNATURE="$(SIGNATURE)" \
        ./gen_mvebu_sdcard_img.sh $@ \
                "$(STAGING_DIR_IMAGE)/clearfog-u-boot-spl.kwb" \
                c 32768 $@.boot \